Hosting Requirements

To ensure best working compatibility, performance and support, all of our WordPress Plugins require the following WordPress and PHP versions to run smoothly.


You must have either:

  • A self-hosted WordPress site, or
  • A installation with the Business Plan or higher.

WordPress Versions

We actively support our Plugins running WordPress 5.0 or higher.

PHP Version

We actively support our Plugins running on any PHP version that is listed as a “Currently Supported Version” at At the time of writing, this is:

  • 7.2
  • 7.3
  • 7.4

Given that older versions of PHP are no longer supported or maintained by the PHP team, it is strongly recommended that you keep your PHP version up to date, to avoid security and performance issues with your WordPress web sites in general.

If you are using PHP 7.1 and older, due to third party legacy Plugins, Themes and code, you will need to work with said third party products to ensure their code is up to date.  Running outdated Plugins due to incompatibility with later PHP versions is another security issue.


PHP must be able to use at least 128MB of memory for correct operation of our Plugins.  256MB or more (in exceptional high use cases) may be required.

You can configure this by adding the following to the end of your wp-config.php file:
define( 'WP_MEMORY_LIMIT', '128M' );


Our Plugins work on most hosting environments.  However, if you’re new to WordPress or looking for a recommendation, we recommend WP Engine, because:

  • WordPress Versions are automatically updated, once tested to ensure stability,
  • PHP Versions are automatically updated, once tested to ensure stability,
  • WP-CLI is included, which some of our Plugins can optionally use for better performance.
  • Sensible memory limits are defined that provide correct working functionality with our Plugins.

Find out more about WP Engine.